End of life van PHP 5.6 en 7.0 en consequenties voor Magento en vtiger CRM

Innovatie vereist vernieuwing


Per 31 december bereikt PHP 5.6 zijn end of life datum. Vanaf dan biedt PHP zelf geen support en veiligheidsupdates meer voor versie 5.6 en wordt de ondersteuning voor versie 7.0 afgebouwd. Vicus legt uit welke gevolgen dit heeft en wat je kunt doen om te zorgen dat je webshop of crm-systeem veilig blijft.

Het ondersteuningsbeleid van PHP

Voor elke PHP-versie wordt vanaf de releasedatum voor gedurende twee jaar ondersteuning gegeven. Tijdens deze periode worden fouten en beveiligingsproblemen verholpen en vrijgegeven in puntsgewijze releases.

Na de actieve ondersteuning voor een periode van twee jaar wordt elke versie nog één jaar lang ondersteund voor kritieke veiligheidsproblemen. Deze security fixes vinden enkel plaats op basis van de behoefte en meldingen van de community.

Zodra de drie jaar van ondersteuning zijn voltooid, bereikt de PHP versie zijn end of life datum en zal deze niet langer meer worden ondersteund. Meer informatie over de support op PHP versies vanuit PHP vind je via deze link. De afbeelding hieronder laat de tijdlijn zien van de support periode per PHP versie:

PHP support

Verlengde ondersteuning voor PHP 5.6 en PHP 7.0?

Hoewel wij het upgraden naar de laatste versie van PHP toejuichen, snappen wij dat er applicaties zijn die een oudere versie van PHP vereisen. Om onze klanten die nog op oude PHP-versies draaien te ontzorgen, kunnen wij in samenwerking met onze leveranciers nog een beperkte periode security patches aanbieden voor PHP-versies die officieel End-of-Life zijn. Vraag ons naar de mogelijkheden als dit voor jou van toepassing is.

Indien je (bijzondere)persoonsgegevens in je systeem opslaan dan raden wij ten zeerste af om nog onder oudere versies van PHP te blijven werken.

Wat betekent dat voor Magento?

Magento logo

Magento ' draait' ook op PHP. Dat betekend dat bovenstaande ook van toepassing is op Magento webwinkels. Magento 1 kan standaard niet op PHP versie 71 of hoger draaien. Daarvoor is een patch nodig.

Stap je al over naar Magento 2.2 of hoger? dan is er niets aan de hand en moet je alleen controleren of de PHP versie op je hostingplatform al op php 7.1 of hoger staat. Klanten van Vicus hebben allemaal al een bericht gehad en een keuze gemaakt.

Heb jij nog een verouderde Magento? en wil je die updaten naar Magento 2? of juist jouw Magento 1 nog in de lucht houden? Neem dan contact met ons op; we kunnen altijd een passende oplossing bieden.

En wat betekent dat voor vtiger crm?

Logo vtiger crm

Ook vtiger is een applicatie die gebouwd is in de programmeertaal PHP. De meest actuele Vtiger versie 7.1 draait bij Vicus ook al op PHP 7.1. Er is nog een enkele plug-in die nog niet PHP 7.1 compatible is. Maar alle plu-in bouwers hebben ons verzekerd dat ze deze achterstand in januari 2019 hebben ingehaald.

Alle klanten van Vicus hebben van ons de afgelopen maanden een bericht ontvangen om een keuze te maken die past bij het gebruik van hun systeem. De meeste hebben de keuze gemaakt om over te stappen naar vtiger versie 7.1. Een enkeling blijft op een oude versie draaien, daarvoor hebben wij een speciale server ingericht die oudere versies van vtiger blijft ondersteunen.


Lees meer over: Magento  ▫  Vtiger CRM


Ga terug